ZwCAD 2023 beta


BKW
 Share

Recommended Posts

W dniu 30.07.2021 o 11:46, BKW napisał:

4. Zachowanie hatcha przy strechowaniu

ZWCAD_2022 - vernum = "22.00_2021.07.07(251ad3fce2f)_x64"

Zwcad_2020_strhatch.thumb.gif.1e527692682266ede8c8490b269e97aa.gif

ZWCAD 2015+ VERNUM = "2015.08.15(27483)

Zwcad_2015_strhatch.thumb.gif.0cc8e6d9c118ade5cdc3a216dd0493fe.gif

Czy istnieje jakaś zmienna, która powoduje takie zachowanie ? Czy to jest błąd ?

5. Łapanie OSNAPów przy ZOOM / WINDOW

Błąd czy też zachowanie zgłaszane przeze mnie chyba od początku ZWCada na nowym silniku. Da się coś z tym zrobić ??

 

Powyższe błędy w dalszym ciągu występują w programie.

Link to comment
Share on other sites

7 godzin temu, BKW napisał:

I mam już pierwsze spostrzeżenie - nie działa import niektórych ustawień (migracja) z wcześniejszych wersji - np. import cuix, profili

Przestałem używać importu, bo od zawsze miałem problem z tym, że część ustawień było importowane a część niestety nie. Nie pamiętam dokładnie, ale chyba był już poruszany ten wątek w przypadku wcześniejszych wydań ZWCADa. 

Ciekaw jestem czy udało się poprawić błąd z łapaniem okienka SMARTRACK TOOLTIPS w przypadku myszek ustawionych na wysokie DPI.
Obecnie pracuję na ZWCAD w wersji 2021 i przy ustawieniu czułości myszki na 3600 DPI notorycznie metka 'daje się złapać'....

Pozostaje przetestować wersję 2023-beta...

Link to comment
Share on other sites

Posted (edited)

1. KURSOR Z POLECEŃ WYWOŁANYCH "LISPOWO"

Przy wywoływaniu poleceń przez skróty zdefiniowane w składni LISP ( np. (DEFUN C:MN () (COMMAND "_MATCHPROP"))) program nie zmienia wyglądu kursora na "moduł selekcji". Przy poleceniu wywołanym z menu bądź wpisanym w całości w pasek komend kursor zachowuje się poprawnie.

ZWCAD_2023_1_lisp.gif.db34d54947b7913c2e8b08754acd0334.gif

Edited by BKW
Link to comment
Share on other sites

W dniu 10.08.2021 o 12:15, BKW napisał:

6. Wyświetlanie polilinii z grubością (vernum = "22.00_2021.07.07(251ad3fce2f)_x64")

Jak widać na poniższym filmie polilinie z nadaną grubością wyświetlają się tak jakby były "skrzywione". Gdy ustawiam grubość na 0 wyświetlanie wraca do normalności. Ktoś miał podobnie ?

Zwcad_2022_grpln.thumb.gif.8608ef5861d1cb1294b1326696762ceb.gif

 

Powyższy błąd w dalszym ciągu występuje w programie. Poniżej potwierdzenie.

ZWCAD_2023_pew.gif.f60c80b0eaa289608006fc0e77e69411.gif

Link to comment
Share on other sites

  • 2 weeks later...
W dniu 28.04.2022 o 14:11, BKW napisał:

I mam już pierwsze spostrzeżenie - nie działa import niektórych ustawień (migracja) z wcześniejszych wersji - np. import cuix, profili

Z ciekawości użyłem funkcji IMPORT po instalacji ZWCAD2023-beta. Niestety migracja ustawień z 2021 bez powodzenia...

 

Obecnie działam na ZWCAD 2021, porównując z 2023-beta widzę znaczącą różnicę w wydajności programu. Program wczytuje pliki dużo szybciej niż 2021, poprawiono wydajność działania na rysunkach. Widać również poprawę w kwestii wyświetlania kursora (krzyża nitkowego) w trakcie ruchu. Nie udało mi się złapać metki narzędzia Smarttrack Tooltips, co w wersji 2021 udaje mi się bez żadnego problemu (uznaję, że problem został rozwiązany).

 

Widać również poprawę w przypadku wyświetlania modeli 3D. Niestety wg mnie słabo działa funkcja obracanie modelu 3D. Przydałoby się coś na wzór VIEWCUBE w AC. Ogólnie jakoś ciężko obraca się modelem 3D w ZWCadzie za pomocą kombinacji SHIFT+CONTROL+Mouse Middle Button.

 

Link to comment
Share on other sites

Zauważyłem problem z działaniem wersji 2021 po zainstalowaniu programu w wersji 2023-beta.

Korzystając z wersji 2021 (wersja PRO ENG, licencja aktywna) program zaczął zacinać się.
Objawiało się to w sposób opóźnionej reakcji na wywoływane komendy lub na klikanie i wybieranie elementów lub obszaru modelu. Program jakby chwilowo zawieszał się, bo przy próbie szybkiego wybrania elementu na chwilę zacinało, a potem kursor/obszar pojawiał się w miejscu, gdzie powinien być po przesunięciu myszki - nie przesuwał się jednak płynnie po ekranie tylko przeskakiwał).
Początkowo po uruchomieniu wersji 2021 i wczytaniu pliku z rysunkiem program działał normalnie, dopiero po kilku minutach zaczynał spowalniać i przycinać. W trakcie pracy na wersji 2021, program w wersji 2023-beta był wyłączony.

Początkowo myślałem, że system Win10 dostał zadyszki dlatego wykonałem kilkukrotnie restart, niestety bez powodzenia.
Sprawdziłem aktualizacje i zainstalowałem nowe sterowniki, również bez rezultatu. Dopiero odinstalowanie BETY pomogło i wersja 2021 zaczęła działać płynnie (bez restartowania i reinstalowania 2021 - chciałem tego uniknąć, żeby wczytywać na nowo ustawień).

Czy dwie różne wersje ZWCADA mogą kolidować ze sobą?

Odrzucam raczej problemy ze względu na sprzęt (AMD Ryzen 5900HX, 32GB RAM, dyski SSD Samsung 970EvoPlus; grafika dedyskowana nVidia RTX 3070 laptop GPU).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share