ZWCAD 2021 - problemy po imporcie konfiguracji z wersji 2020. Problem z kopiowaniem i wklejaniem [rozwiązany]


Chris
 Share

Recommended Posts

ZWCAD 2021 PRO vernum = "2020.08.20(58820)_x64"
System Windows 7 PRO

Czy u kogoś jeszcze nie wyświetla się na dole pasek z ikonami dostępu opcji GRID, OTHO, DYNINPUT itd (przyciski funkcyjne F3, F8, F9, F12 itd)?
Załączam screena z oznaczeniem miejsca,  o którym piszę powyżej.

Dodam, że zainstalowałem wcześniej polską wersję programu i miałem ten sam problem. Odinstalowałem PLK, wyczyściłem clenaerem rejestr i zainstalowałem ponownie program w wersji ENG i problem braku ikon ciągle występuje. Ikony jakby były w tym miejscu zadokowane, ale nie wyświetlają się. Po najechaniu kursorem na miejsce, gdzie powinny być ikony wyświetla się podpowiedź i można PPM rozwinąć MENU i wejść w opcje.

ZWCAD 2021 - brak ikon.PNG

Edited by Chris
Link to comment
Share on other sites

8 minut temu, pawmal napisał:

Proszę zmaksymalizować program lub na dolnej ikonie "od wł. przezroczystości" kliknąć prawym przyciskiem myszy i przełączyć użycie ikon.

Program był kilka razy maksymalizowany.
Przy opcji USE ICON jest ptaszek, czyli zakładam, że jest włączona.
 

Po kliknięciu i odznaczeniu tej opcji pojawiły się dodatkowe opcje, ale w formie opisów, a nie ikon.
Coś ogólnie w tym pasku u mnie nie działa poprawnie.

Brak ikon (poza tą od transparentności), zamiast tego są opisy. Przy próbie przełączenia na ikony nic nie dzieje się.
@pawmal dziękuję za pomoc. W takiej formie też jest OK.

Ciekawi mnie tylko czy ktoś inny ma podobne problemy z tym paskiem?

Edited by Chris
Link to comment
Share on other sites

Dnia 30.06.2020 o 10:36, BKW napisał:

Kilka szybkich spostrzeżeń:
1. Płynność zoomowania i działania programu na tym samym pliku a różnych wersjach oprogramowania ( 2015+, 2020 ) zdecydowanie na minus. Mam wrażenie, że występują "mini zawieszenia" przy każdej komendzie.
2. Polecenie zoom dalej "łapie" osnapy
3. Polecenie refedit - przy edytowaniu bloku i wyjściu z polecenia refedit program dalej pokazuje caaaaaaaaały rysunek wyszarzony, ale z możliwością rysowania poza blokiem. Nie da się zapisać, gdyż program krzyczy, że dalej aktywne jest polecenie refedit (chociaż tak nie jest). Rysunek powraca do normalności po kolejnym użyciu polecenia refedit i anulowaniu edycji bloku.
4. Przy poleceniu zoom znika "krzyż" - nie zawsze, ale bardzo często.
5. Obsługa 2 monitorów - nie da się ustawić programu zmaksymalizowanego na jednym monitorze - zawsze maksymalizuje się na jednym z monitorów - nigdy na drugim. Z kolei polecenie CLEANSCREENON pozwala na maksymalizację programu w dowolnym monitorze.

To tak na szybko. Być może są to błędy programu wystepujące tylko na moim sprzęcie (zainstalowany zwcad 2015+, 2017, 2018, 2019, 2020, 2021beta). Być może część błędów występuje tylko przy pracy z dwoma monitorami (pierwszy raz testuję pracę programu na 2 monitorach - zwcad15+ działa bez zarzutu)
 

Kilka spostrzeżeń do tego co pisałem odnośnie wersji BETA:
vernum = "2020.08.20(58820)_x64"

2. NIE POPRAWIONO - doprecyzuje : przy zoomowaniu z podkomendą WINDOWS

3. NIE POPRAWIONO - poniżej gif

zw2021_refedit.gif.8b8d3f301b179d5deb93ba56b0571f76.gif

 

Edited by BKW
Link to comment
Share on other sites

Dnia 27.08.2020 o 12:07, BKW napisał:

VERNUM = "2020.07.25(58130)_x64"
10. Podczas wymuszania pkt przecięcia się 2 linii następuje dziwne zachowanie - program chwilę się zacina a następnie umieszcza przenoszony (kopiowany) element w całkiem innym miejscu lub zostawia w tej samej pozycji. Poniżej gif

zw2021b2_intersection.gif.460262f2ae1fa81bf839ebde74635100.gif

Z kolei gdy chcę złapać pkt przecięcia przenoszonych elementów program "zawiesza się", a w zasadzie okno rysowania. Nie da się nic w nim zrobić, ale komendy da się wprowadzić (chociaż program nie reaguje na nie). Poniżej gif

zw2021b2_intersection2.gif.1098cdf1898f7bd581ffb03146ef663e.gif

 

Dnia 6.08.2020 o 13:09, BKW napisał:

9. Przy próbie selekcji obiektów co jakiś czas znika krzyż i nie widać co się zaznacza.

zw2021b2_selekcja.gif.af4755d4c012ab64971c36639b8ed574.gif

Wygląda na to, że powyższe problemy zostały rozwiązane.

Link to comment
Share on other sites

vernum = "2020.08.20(58820)_x64"
11. Mam problem z kopiowaniem elementów przez schowek. Przy wywołaniu polecenia "_copyclip" lub "_copybase" pojawia się komunikat o tym, że elementy zostały skopiowane. Po wywołaniu polecenia "_pasteclip" lub "_pastespec" nic się nie dzieje

Link to comment
Share on other sites

6 minut temu, BKW napisał:

vernum = "2020.08.20(58820)_x64"
11. Mam problem z kopiowaniem elementów przez schowek. Przy wywołaniu polecenia "_copyclip" lub "_copybase" pojawia się komunikat o tym, że elementy zostały skopiowane. Po wywołaniu polecenia "_pasteclip" lub "_pastespec" nic się nie dzieje

Potwierdzam, u mnie jest ten sam problem.

Link to comment
Share on other sites

Godzinę temu, pawmal napisał:

Można spróbować przywrócić ustawienia przez reset profilu przez zmianę nazwy katalogu z odpowiednią wersją językową i sprawdzić:
%appdata%\ZWSOFT\ZWCAD\2021

Nie pomogło. Pasek na dole pozostaje w formie opisowej.
Jeśli wybiorę USE ICON to pojawia się tylko jedna z ikon, ta odpowiedzialna za funkcję TRANSPARENCY.
Jeśli chodzi o pozostałe to brak reakcji.

Link to comment
Share on other sites

3 godziny temu, BKW napisał:

vernum = "2020.08.20(58820)_x64"
11. Mam problem z kopiowaniem elementów przez schowek. Przy wywołaniu polecenia "_copyclip" lub "_copybase" pojawia się komunikat o tym, że elementy zostały skopiowane. Po wywołaniu polecenia "_pasteclip" lub "_pastespec" nic się nie dzieje

Czy jest jakieś sensowne i proste obejście tego błędu???

Link to comment
Share on other sites

13 godzin temu, Chris napisał:

Czy jest jakieś sensowne i proste obejście tego błędu???

Obejście jest, ale na pewno nie jest to rozwiązanie sensowne.
Należy popróbować zabawy z poleceniem "-wblock" oraz "-insert".
Dla mnie błąd ten dyskwalifikuje aktualną wersję programu.

Link to comment
Share on other sites

17 godzin temu, BKW napisał:

vernum = "2020.08.20(58820)_x64"
11. Mam problem z kopiowaniem elementów przez schowek. Przy wywołaniu polecenia "_copyclip" lub "_copybase" pojawia się komunikat o tym, że elementy zostały skopiowane. Po wywołaniu polecenia "_pasteclip" lub "_pastespec" nic się nie dzieje

Dodam tylko, że problem jest w poleceniu KOPIOWANIA. Skopiowanie elementów np. w ZWCAD 2015+ i wklejenie ich w ZWCAD 2021 działa - odwrotna sekwencja nie działa.

Link to comment
Share on other sites

Godzinę temu, BKW napisał:

Obejście jest, ale na pewno nie jest to rozwiązanie sensowne.
Należy popróbować zabawy z poleceniem "-wblock" oraz "-insert".
Dla mnie błąd ten dyskwalifikuje aktualną wersję programu.

Dzięki. Rzeczywiście można to w ten sposób obejść.
Nie jest to tak proste i szybkie jak kombinacja klawiszy CTRL+C/CTRL+V (alternatywnie CTRL+SHIFT+C/CTRL+SHIFT+V), ale zawsze to jakieś obejście...

Mam nadzieję tylko, że ZWSOFT poprawi szybko ten błąd nie czekając do wydania SP1.

Link to comment
Share on other sites

3 godziny temu, BKW napisał:

Dodam tylko, że problem jest w poleceniu KOPIOWANIA. Skopiowanie elementów np. w ZWCAD 2015+ i wklejenie ich w ZWCAD 2021 działa - odwrotna sekwencja nie działa.

Problem z kopiowaniem raczej wynika z tego, że obiekty w wersji 2021 posiadają więcej atrybutów, których wersja 2015 nie rozpoznaje, np. przezroczystość obiektów.

Po upływie 30 dni testowania kopiowanie przez schowek jest wyłączane.

Generalnie wersja testowa po upływie 30 dni od instalacji posiada następujące ograniczenia:

  • brak eksportu,
  • druk ze znakiem wodnym,
  • publikowanie tylko do formatu DWF,
  • brak zapisu do formatu DXF.
  • zapis plików DWG tylko do 1000 obiektów,
  • WBLOCK działa tylko do 1000 obiektów,
  • brak możliwości kopiowania obiektów do schowka.

 

Link to comment
Share on other sites

2 godziny temu, dmatusz3 napisał:

Problem z kopiowaniem raczej wynika z tego, że obiekty w wersji 2021 posiadają więcej atrybutów, których wersja 2015 nie rozpoznaje, np. przezroczystość obiektów.

Problem polega na ty, że kopiowanie nie działa z wersji 2021 do wersji 2021. W wersji beta nie było żadnego problemu z kopiowaniem między 2015+ a 2021 i na odwrót, więc się z Panem nie zgodzę.

2 godziny temu, dmatusz3 napisał:

Po upływie 30 dni testowania kopiowanie przez schowek jest wyłączane.

OK, ale ten czas nie minął, więc być może program "sam" wyłączył możliwość kopiowania pomimo nie przekroczonego czasu testowania.

Link to comment
Share on other sites

27 minut temu, dmatusz3 napisał:

Proszę spróbować dezaktywować licencję ZWCAD na komputerze i aktywować ją ponownie.

Klucz dezaktywowałem przed pierwszym uruchomieniem wersji testowej, więc od razu wyskoczył mi czas testowania 30 dni.

obraz.png.6c7bfa2a796db8e0378113fa482aa9a7.png

Link to comment
Share on other sites

Dnia 2.09.2020 o 13:17, BKW napisał:

vernum = "2020.08.20(58820)_x64"
11. Mam problem z kopiowaniem elementów przez schowek. Przy wywołaniu polecenia "_copyclip" lub "_copybase" pojawia się komunikat o tym, że elementy zostały skopiowane. Po wywołaniu polecenia "_pasteclip" lub "_pastespec" nic się nie dzieje

Problem rozwiązałem poprzez deintalację ZWCADA 2021, wyczyszczenie rejestrów (łącznie z ręcznym wyrzucaniem wszystkich katalogów powiązanych z ZWCAD 2021) oraz ręczne usunięcie wszystkich folderów pozostałych na dysku systemowym po odinstalowaniu wersji 2021.
Po ponownym zainstalowaniu programu polecenia: "_copyclip"; "_copybase", "_pasteclip" oraz "_pastespec" działają poprawnie.

Link to comment
Share on other sites

7 godzin temu, Chris napisał:

Problem rozwiązałem poprzez deintalację ZWCADA 2021, wyczyszczenie rejestrów (łącznie z ręcznym wyrzucaniem wszystkich katalogów powiązanych z ZWCAD 2021) oraz ręczne usunięcie wszystkich folderów pozostałych na dysku systemowym po odinstalowaniu wersji 2021.
Po ponownym zainstalowaniu programu polecenia: "_copyclip"; "_copybase", "_pasteclip" oraz "_pastespec" działają poprawnie.

Przeinstalowałem program, wyczyściłem rejestry, przed ponowną instalacją usunąłem foldery z ustawieniami użytkownika - po ponownej instalacji i uruchomieniu programu w ustawieniach "startowych" kopiowanie działa.

Następnie włączyłem kreator migracji - i po zaimportowaniu ustawień z zwcada2020 kopiowanie nie działa.

Link to comment
Share on other sites

6 minut temu, BKW napisał:

Przeinstalowałem program, wyczyściłem rejestry, przed ponowną instalacją usunąłem foldery z ustawieniami użytkownika - po ponownej instalacji i uruchomieniu programu w ustawieniach "startowych" kopiowanie działa.

Następnie włączyłem kreator migracji - i po zaimportowaniu ustawień z zwcada2020 kopiowanie nie działa.

Miałem podobne podejrzenia co do migracji ustawień, dlatego wykonałem instalację i podobnie zrezygnowałem z migracji.
Sprawdziłem czy kopiowanie działa i po weryfikacji wykonałem migrację podstawowych ustawień drukarki, czcionek, linii, kreskowań oraz pliku pgp z komendami.
Zrezygnowałem z migracji pliku CUIX oraz Profilu i w moim przypadku kopiowanie działa dalej.
 

Link to comment
Share on other sites

3 minuty temu, Chris napisał:

Miałem podobne podejrzenia co do migracji ustawień, dlatego wykonałem instalację i podobnie zrezygnowałem z migracji.
Sprawdziłem czy kopiowanie działa i po weryfikacji wykonałem migrację podstawowych ustawień drukarki, czcionek, linii, kreskowań oraz pliku pgp z komendami.
Zrezygnowałem z migracji pliku CUIX oraz Profilu i w moim przypadku kopiowanie działa dalej.
 

Reset ustawień do tych fabrycznych przywraca zdolność programu do kopiowania.
Podejrzewam, że w 2021 jest inaczej zdefiniowane makro związane z KOPIOWANIEM niż w wersji 2020 i podczas migracji jest ono razem z CUIX importowane. Ale to tylko moje podejrzenia.

Link to comment
Share on other sites

3 godziny temu, dmatusz3 napisał:

Tutaj jest program usuwający całkowicie wersję 2021 z systemu operacyjnego https://jakicad.pl/pobierz/1003/ZwFixIt2021.exe

Usuwa zarówno wersję 32 jak i 64 bit i wszystkie wersje językowe.

A czy po zastosowaniu tego programu, a później po zainstalowaniu ponownie wersji 2021 i skorzystaniu z kreatora migracji, Zwcad2021 będzie zezwalał na korzystanie z funkcji kopiowania ?

Link to comment
Share on other sites

  • dmatusz3 changed the title to ZWCAD 2021 - problemy po imporcie konfiguracji z wersji 2020. Problem z kopiowaniem i wklejaniem [rozwiązany]
  • dmatusz3 locked this topic
Guest
This topic is now closed to further replies.
 Share