Bartek1977

Brak przezroczystości polilinii

Rekomendowane odpowiedzi

EDYCJA. Niestety faktycznie problem występuje - moja pomyłka, otworzyłem sobie nie ten plik z polilinią (w przypadku poniżej była ustawiona szerokość linii zamiast szerokości polilinii).

Prosiłbym jednak o podpowiedź.

Porównuję pod tym względem 2015 i 2018 (vernum = "2017.09.18(21849)_x64") i przyznam, że trudno mi wychwycić różnicę. Bo jak rozumiem chodzi tutaj o przesuwanie wierzchołków polilinii.

Tak działa to w 2015

edycja_polilinii_2015.gif

a tak w 2018

edycja_polilinii_2018.gif

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Obiecali, że poprawią w SP1 i nic z tego. Polilinia wcale nie jest przezroczysta, tylko po złapaniu za punkt i próbie przesunięcia miga jak szalona, dlatego czasami widać snapy, ale można oczopląsów dostać. To nie jest rozwiązanie.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

HEHE trzeba przyznać, że to im się udało! Porównałem sobie działanie ZWCADA z konkurencyjnymi CADami i przyznaję, że ZWCAD wypada w tym konkretnym przypadku najgorzej... Zaznaczę tylko, że konkurencyjne CADy są wersjami z 2015r.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Opracowaliśmy LISPa, który w pewnym stopniu ułatwi przesuwanie wierzchołków polilinii, do czasu globalnego rozwiązania problemu.

Po jego załadowaniu będzie dostępne polecenie zz. Jego uruchomienie włącza inny tryb wyświetlania edytowanej polilinii.

Aby powrócić do normalnego trybu wystarczy ponownie wpisać zz

polilinia_zz.gif

 

Skrypt do pobrania zz.lsp

Kod źródłowy

;;;
;;;www.zwcad.pl | Skrypt przełączający widoczność polilinii o zadanej globalnej grubości.
;;;

(defun C:ZZ (  / *error* )
	(defun *error* ( msg / ) 
		(if (not (null msg ) )	(progn (princ "\nC:ZZ:*error*: " ) (princ msg ) (princ "\n")	) )
	)
	
	( if ( = (getvar "FILLMODE" ) 0 )
		(progn ( setvar "FILLMODE" 1 )(command "_REGEN") )
		(progn ( setvar "FILLMODE" 0 )  )
	)
	(princ "" )
)

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Vernum 2018.02.11 x64

Nic się niestety nie zmieniło względem SP1, dalej miga.  W 2015 zaznaczona polilinia nie jest przezroczysta, tylko jest tak jakby przesunięta na spód rysunku, ponieważ widoczne są wszystkie obiekty nad nią. Może informatycy z Zwsoftu poszli nie w tym kierunku, próbując zrobić przezroczystą polilinię...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Na forum Zwsoftu odpowiedzieli, że od SP1 działa przezroczystość polilinii i wstawili screena. Nie wiem jak to zrobili, bo u mnie to tak nie wygląda. Możliwe, że nie wprowadzili tego do ogólnodostępnej wersji? Możecie się dowiedzieć dlaczego tak jest?

polilinia.png.7bf5bdeba9683b6bece3e2b97e452573.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się