ZWCAD+ Pro i wykorzystanie procesora


dszemraj
 Share

Recommended Posts

Witam

Na wstępie jako nowy użytkownik chciałem się przywitać i pozdrowić Wszystkich użytkowników forum.

W czym problem…

Przeniosłem się z wersji ZWCAD 2012 Pro na wersję ZWCAD+ 2012 Pro SP1 vernum 2012.12.14 (8707)

Na aktywnym krzyżu na oknie modelu lub layout w wydajności użycia procesora pokazuje że ZWCAD.exe *32 utrzymuje się cały czas na poziomie 25% (dwa rdzenie na zmianę są w ciągłym użyciu), w monitorze zasobów brak jest uwag w łańcuchu oczekiwań przy tym procesie, wg systemu ZWCAD działa poprawnie.

Tak się dzieje niezależnie czy jest pusty rysunek, czy otwarty duży plik, czy się rusza myszką czy nie.

Co ciekawe, użycie procesora spada do poziomu 0% jak się wywoła jakiekolwiek okno w ZWCAD+ np. opcje, abaut itd.

Próbowałem przeinstalowywać ZWCAD+, udinstalowywać starszą wersję 2012 z wsadzonym kluczem sprzętowym czy bez zawsze jest tak samo 25% i nic nie przynosiło oczekiwanego efektu, żadnej poprawy.

Dodam że pracuje na laptopie i takie wykorzystanie procesora praktycznie uśmierca baterie w błyskawicznym tempie. Przy starszej wersji ZWCAD 2012 jak się nie ruszało myszką to poziom użycia procesora był 0%

System operacyjny Windows 7 Prof. 64bit z wszystkimi niezbędnymi łatkami, pamięć 8GB, procesor i7 M620, licencja klucz sprzętowy.

Proszę Was o pomoc z rozwiązaniem tego problemu. Przypuszczam, że została jakaś kolidująca biblioteka po ZWCAD 2012 Pro, chociaż po jej odinstalowaniu starałem się usunąć wszystko z dysku łącznie z czyszczeniem rejestru.

Pozdrawiam

Edited by dszemraj
Link to comment
Share on other sites

Witam,

pojawia się zatem też pytanie, na jakim poziomie jest zużycie procesorów gdy ZwCAD nie jest włączony?

Bo skoro jest stały poziom zużycia, bez względu na to co się wykonuje w programie, to to troszkę dziwnie wygląda.

Otwieranie okien systemowych, to uruchamianie nowego procesu, więc powinien następować wzrost zużycia, a nie spadek do 0%.

Sprawdzał Pan różnice w przypadku pracy na baterii oraz na kablu (bez baterii)?

pozdrawiam

Link to comment
Share on other sites

Witam

Może niejasno opisałem problem.

Zużycie procesora przy wyłączonym ZWCAD+ jest znikome, bliskie 0% mimo że w tle chodzą inne programy (Office itd).

Dopiero kiedy jest włączony ZWCAD+ i jest aktywny krzyż (możemy rysować itd) cały czas proces ZWCAD zużywa 25%, a jeżeli wywołam polecenie otwarcia okna w ZWCAD np opcjie programu lub informacje o wersji porogramu zużycie spada do poziomu 0%

Na kablu czy samej baterii jest tak samo.

Przy włączonych lub pozamykanych wszystkich programach, działa sam ZWCAD+ zużycie tego procesu zabiera zawsze 24-25%

Dziekuje za zainteresowanie, czekam na pomysły rozwiązania tego problemu

Pozdrawiam

Edited by dszemraj
Link to comment
Share on other sites

Witam

Najechanie kursorem na wyciągnięte ikony nie odpuszcza procesorowi ale

włączenie jakiegokolwiek paska rozwijanego typu File, Edit, View itd powoduje spadek zużycia do 0% to samo się dzieje jak wywołam z prawego przycisku myszy szybkie menu, przy rozwinietym pasku rownież zużycie spada do zera.

Zejście kursorem z paskòw ZWCADa i ich zwinięcie momentalnie szarpie procesorem na te 24-25%

Nie zauważyłem tego wcześniej bo zwykle wywołanie komendy z paskòw trwa przysłowiowy ułamek sekundy

Mam nadzieję że ta anomalia naprwadzi Państwa na wykrycie tej nieprawidłowości z wykorzystaniem procesora przez ZWCAD+

Pozdrawiam

Link to comment
Share on other sites

Witam,

u mnie sprawa wygląd tak, że w chwili "latania" kursorem po obszarze roboczym ZwCAD,

procesor ma skaczące zużycie rzędu 5-22%:

post-94-0-47993400-1361171253_thumb.jpg

Wyłączenie podglądu Coordinates, niewiele pomaga.

Nie jest to jednak ciągłe 25%

Można jeszcze sprawdzić, czy zmiany parametrów w Opcje / Wyświetlanie, cokolwiek zmieniają.

pozdrawiam.

Link to comment
Share on other sites

Witam

Od tego zacząłem, próbowałem zmieniać wszelkie ustawienia ale nie przynosiły żadnego efektu

Wygląda to mniej więcej tak

post-501-0-10636100-1361178528_thumb.jpg

Górna część zdjęcia z aktywnym ekranem do rysowania

Dolna z włączonym menu podręcznym (to samo jest jak włączę menu rozwijane lub okienko z ZWCAD+

Pozdrawiam

Edited by dszemraj
Link to comment
Share on other sites

  • 2 weeks later...

Witam

U mnie problem ze stałym obciążeniem pojawił się po wznowieniu systemu ze stanu uśpienia. Uśpiłem komputer z otwartym rysunkiem. Po wznowieniu pracy ZWCAD+ nie reagował na żadne komendy, nie mogłem też odświerzyć ani zamknąć rysunku - zamknięcie aplikacji awaryjnie dopiero przez menadźera zadań. Obciążenie procesora na poziomie 25% (nie wiem dlaczego na zrzucie z ekranu zmiania na 24% - kilka prób, zawsze zmniejsza o 1% :) ). Miałem otwarty niewielki plik z podpiętym Xref w postaci pliku DWG z podkładem architektonicznym.

Pozdrawiam

post-489-0-55311500-1361873046_thumb.jpg

Link to comment
Share on other sites

Witam

Coś jest na rzeczy z tym wykorzystaniem procesora.

Najprawdopodobniej jest to jakaś biblioteka systemowa lub wpis w rejestrze który powoduje takie zachowanie ZWCAD'a+

U mnie tak jak pisałem, na aktywnym oknie graficznym ZWCAD+ wykorzystuje zawsze te 24-25%.

Komputer nie wprowadzam w stan uśpienia, zamykam całkowicie system.

W temacie rozłożyłem ręce i pozostaje mi jedynie czekać na nowszą wersję ZWCAD+.

Może ona coś pomoże.

Pozdrawiam

Link to comment
Share on other sites

  • 2 months later...
  • 11 months later...

Witam

Aktualizacja do ZWCAD+ 2012 SP2 vernum 2013.03.31 (11367)

Nie przyniosła oczekiwanej przeze mnie poprawy, opisywany problem dalej mam nierozwiązany icon_cry.gif

Pozdrawiam

 

Witam,

u mnie identyczny problem pojawił się w wersji ZWCAD+ 2014. Stąd pytanie. Czy udało się może komuś ustalić przyczynę i znaleźć rozwiązanie?

Pozdrawiam

Link to comment
Share on other sites

Ja mam następującą obserwację:

Win7 x64 laptop 4GB Ram CoreDUO ZwCAD+ 2014

Po uruchomieniu ZwCAD'a przy braku aktywności w programie utylizacja 0-1%

Ładuję aplikację VBA w moim przypadku nakładka e-cad.

Przy braku aktywaności jeden rdzeń idzie na 100% ( czyli ogólnie utylizacja powyżej 50% )

Zaczynam machać krzyżem nitkowym na polu roboczym w lewo i w prawo utylizacja procesora dla ZwCAD'a spada do ok.4-6%

Przestaję machać mychą - utilizacja na 100% jednego rdzenia

Rozwijam górne menu nie wskazując żadnej opcji - utylizacja 0% !!!

Otworzenie jakiegokolwiek okna czy to standardowego ZwCAD'a czy to okna nakładki e-cad - utylizacja 0%

Zamknięcie wszystkich okien powoduje wzrost utilizacji na 100%

Wystarczy jednak klikąć myszką w pole robocze np. rozpoczynąc selekcję obiektów ( których nie ma bo mam pusty rysunek ) utylizacja spada do 0%

 

Dodam jeszcze, że na drugim stanowisku z WinXP identyczna wersja ZwCAD i e-cad zjawisko nadmiernej utylizacji procesora w stanie bezczynności NIE WYSTĘPUJE.

 

Konkluzja:

U mnie wzrost utylizacji procesora występuje po załadowaniu aplikacji VBA w czasie bezczynności gdy krzyż nitkowy jest w bezruchu na polu roboczym.

Problem chyba jest na styku ZwCAD+  <-> Win7 64bit z wmieszaniem w to interpretera VBA.

Edited by perlon
Link to comment
Share on other sites

Witam

Problem 25% u mnie z przed ponad roku jest cały czas, pomimo różnych aktualizacji i zainstalowanych nakładek typu e-cad itp.

Powiem szczerze, że liczyłem na ZwCAD+2014, ale z tego co piszecie pewnie problem zostanie.

Radze sobie w ten sposób, że jak odchodząc od komputera lub chwilowo nie potrzebuje cada włączam jakiekolwiek okno komendy w ZwCad, najczęściej Options (OP) i wtedy mam ~0% na procesorze.

 

Szczęście w nieszczęściu, ale cieszy mnie to, że nie jestem odosobniony z tym problemem, może przyczyni się to do szybkiego rozwiązania problemu i ktoś się z tym rozwiązaniem podzieli na grupie.

 

Pozdrawiam

Link to comment
Share on other sites

Witam

Proszę spróbować wyłączyć automatyczne aktualizacje. Można to zrobić wpisując w pasku poleceń _configupdate i Enter. W oknie proszę odznaczyć (wyłączyć) opcję Włącz automatyczne aktualizacje i kliknąć przycisk Zapisz.

Pozdrawiam

Link to comment
Share on other sites

Witam

Proszę spróbować wyłączyć automatyczne aktualizacje. Można to zrobić wpisując w pasku poleceń _configupdate i Enter. W oknie proszę odznaczyć (wyłączyć) opcję Włącz automatyczne aktualizacje i kliknąć przycisk Zapisz.

Pozdrawiam

W ZWCAD+ 2012 nie wchodzi mi to polecenie

 

Command: _configupdate

Unknown command "CONFIGUPDATE".  Press F1 for help.

 

Ad. Areo

Pracuje od początku na klasycznym ustawieniu Windowsa i ZwCada

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share