qsek

Problem z uruchomieniem nakładki w ZWCAD 2019 SP2 Beta

Rekomendowane odpowiedzi

vernum 2018.12.25(40891)_x64

Windows 8.1

image.png.d11db86917cb1f94408b4374fe1404d4.png

Mam problem z uruchomieniem nakładki w w/w programie ZWCAD jak w temacie.

Przechodzę procedurę zgodnie z instrukcją: http://www.e-cad.pl/_forum/viewtopic.php?f=20&t=28

brakuje mi jedynie ostatniego kroku czyli ustawień bezpieczeństwa.

Zgodnie z instrukcją pierwszego uruchamiania w instrukcji ściągniętej z programem może pojawić się takie okienko: 

image.png.1ba7c86730ed571bd116b2ef457f5a91.png

nic takiego się nie pojawiło.

Gdy próbuje włączyć ręcznie macro przez Manage>>Applications>>VBA Manager,

następnie ładuję plik "e-cad_stal_drewno.zvb" wyskakuje okienko

image.thumb.png.8756ffb455dc1aee6bf2913178e1a4d3.png

klikam "enable macros iii zwcad informuje mnie o błędzie otwierania VBA project 

 

 

 

image.png

Edytowane przez qsek
powtórzony plik jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Proszę sprawdzić jaką wersję VBA ma Pan zainstalowaną?

W ZWCAD proszę przytrzymać lewy ALT i wcisnąć F11.|
Otworzy się edytor VBA.
Następnie wybieram z górnego menu HELP opcję ABOUT MICROSOFT VISUAL BASIC.

Powinna być zainstalowana wersja 7.1

Sprawdziłem właśnie na ZWCAD 2019 Professional vernum="2018.09.13(37516)_x64" działa bez zarzutów.

Proszę spróbować przeinstalować ZWCAD, być może pomoże to wskrzesić środowisko VBA.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Czyli środowisko VBA nie zainstalowało się.

Może Pan spróbować zainstalować poprzednią kompilację ZWCAD 2019 i tym samym zainstaluje się poprawnie VBA.
Następnie spróbować uruchomić nakładki w ZWCAD 2019 Beta.

Ponieważ jest to wersja Beta, musimy poczekać do oficjalnej wersji, w której zapewne Producent ZWSOFT przywróci pełną funkcjonalność ZWCAD.

 

Na poprzednich (oficjalnych) kompilacjach ZWCAD 2017, 2018, 2019 Professional nakładki e-CAD działają prawidłowo.
Dlatego zachęcam do użytkowania oficjalnych wersji ZWCAD.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Okazuje się, że wszystko działa prawidłowo.

Właśnie sprawdziliśmy działanie nakładek e-CAD na najnowszej wersji ZWCAD 2019 Professional SP2 Beta (vernum = "2018.12.25(40891)_x64"), czyli na tej na której Pan próbował uruchomić. Przypuszczamy, że problem leży w Pana systemie Windows i braku możliwości uruchomienia środowiska VBA. Jeżeli zainstaluje Pan prawidłowo środowisko VBA w Windows to również nakładki się uruchomią, ponieważ korzystają one właśnie z tego środowiska w ZWCAD.

Wszystko działa poprawnie i w dodatku bardzo szybko. Mało tego, wydaje nam się, że teraz ZWCAD jest jeszcze szybszy, a nakładki e-CAD działają w nim błyskawicznie!

e-cad_zwcad_2019_sp2_beta.png

Edytowane przez e_CAD

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

no też myślę że to z moim środowiskiem VBA jest coś nie hallo, bo na innych komputerach nie mam tego problemu

tylko nie mam pojęcia jak to rozwiązać 😞

po przeinstalowaniu do oficjalnej wersji ZWCAD 2019 SP1 2018.10.23(38586)_x64 nadal ten sam problem

image.thumb.png.8115c3ffdc63a7858bc3a4fb75ab59e9.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Być może jest to kwestia bezpieczeństwa w Windows 8 i być może użytkownik Windows nie ma odpowiednich uprawnień.

A czy np. w Excelu otwiera się Panu Edytor VBA? (lewy ALT + F11)

Musi Pan doprowadzić do sytuacji, w której będzie poprawnie zainstalowane środowisko VBA na Pana komputerze, czyli będzie mógł Pan wejść do Edytora VBA w ZWCAD.

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Proszę odszukać poniższe klucze w rejestrze, usunąć je i sprawdzić:

ZWCAD 64 bit: HKEY_CLASSES_ROOT\TypeLib\{EC92300D-5A17-11E7-B72E-BC5FF42AC839}\1.0\0\win64
ZWCAD 32 bit: HKEY_CLASSES_ROOT\TypeLib\{EC92300D-5A17-11E7-B72E-BC5FF42AC839}\1.0\0\win32

2019-01-28 08_59_42.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

edytor VBA w excelu działa

po usunięciu wskazanych kluczy z rejestru nadal nie działa, ten problem mam na laptopie bo mi PC padł.

Na szczęście udało mi się postawić PC z Windows 10 i tu mi wszystko hula bez problemu, więc sprawa nie jest taka pilna.

Laptopa z problemem posiadam jednak nadal :(.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

2018.12.25(40891)_Win32

jak zainstalowałem wersję 32 bit ZWCAD to rzeczywiście wszystko działa, mało tego pokazuje mi wersję 7.1 VBA (to na PC w domu gdzie również mam Windows 8.1 i jest taki sam problem)

image.thumb.png.71b948e53dbbc1bb8d4d1d56ae9b93db.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się