Problem z przesuwaniem obiektów


beryl
 Share

Recommended Posts

Witam wszystkich forumowiczów.

Od wczoraj testuję ZWCAD'a i od razu mam taki problem. Otóż, podczas przesuwania jakiegokolwiek obiektu znika zarówno sam obiekt jak i krzyż kursora. Widoczna jest jedynie linia łącząca punkty bazowy i końcowy przesunięcia. Wszystko wraca do normy w momencie zatrzymania kursora. Czym może to być spowodowane?

Mam Windows XP SP2.

Pozdrawiam

Link to comment
Share on other sites

Witam,

ruch kursora ma priorytet nad odświeżaniem kopiowanych czy przesuwanych elementów.

Dzięki temu można płynnie ruszać wskaźnikiem myszki.

Linia z punktu początkowego do końcowego wskazuje wektor przesunięcia.

Zatrzymanie myszki na ułamek sekundy powoduje wyświetlanie wszystkich kopiowanych elementów.

Odświeżanie też zależy od ilości przesuwanych elementów, oraz prędkości poruszania myszką.

Jak dla mnie, zachowanie programu jest jak najbardziej normalne.

Chętnie zobaczylibyśmy jak wygląda to u Państwa na komputerze.

Jeśli tak, to proszę o wiadomość.

Pozdrawiam

Link to comment
Share on other sites

  • 1 month later...

Podłączam się pod pytanie, bo jak widzę problem nie został jeszcze rozwiązany. Moja wersja programu: "2009.07.30(11052)" (read only), system: win xp sp2, parametry komputera: Intel core duo 2GHz, 2GB RAM. Opisany wyżej problem z migotaniem jest dość irytujący. Dodam, że migotanie elementu razem z kursorem występuje nawet wtedy, kiedy rysunek jest pusty, a chcemy przekopiować jedną kreskę. W Autocadzie LT 2008 odświeżanie kopiowanego elementu jest płynne, w przypadku ZWCada - bije nieco po oczach. Zastanawiam się nad zakupem IMO bardzo dobrego programu ZWcad, jednak ta wada niestety go dyskwalifikuje. Z tego co widziałem, podobny problem występował też w konkurencyjnym programie opartym na jądrze Intellicad. Pozdrawiam

Link to comment
Share on other sites

Komenda zoomspeed nieznacznie poprawia problem, niestety nadal znikają hatche, wszelkie podkłady, jeśli ktoś dłubie nad plikiem z dużą ilością hatchy (np. drogi) to można oczopląsu dostać, czekamy na jakieś rozwiązanie lub łatkę poprawiającą ten problem.

Link to comment
Share on other sites

Witam,

wydaje mi się że posty tutaj dotyczą dwóch różnych problemów:

1. odświeżanie obrazu podczas kopiowania i przesuwania elementów

2. odświeżanie obrazu podczas przesuwania i skalowania obrazu.

Domyślnie ZWCAD jest ustawiony aby wyłączał kreskowanie podczas przesuwania i skalowania obrazu. W załączeniu zamieszczam film, o tym jak wyłączyć tą opcję.

Pozdrawiam

kreskowanie_podczas_przesuwania.avi

Link to comment
Share on other sites

  • 2 weeks later...

No tak zoomspeed = 0 zdecydowanie poprawił wyświetlanie przy przesuwaniu widoku oraz zoomie ze scrolla.

Ale przy edycji obiektów znikanie (migotanie) występuje nadal. Mnie to bardzo przeszkadza. Do tej pory pracowałem na AutoCadzie - wszelkie operacje prowadziły się bardzo płynnnie. Czy jednak nie możnaby czegoś z tym zrobić?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share