Problem z nakładkami do ZWCAD


root65
 Share

Recommended Posts

Witam

Po - mam nadzieję - poprawnym zainstalowaniu nakładek (według instrukcji): TOOLS i Wydruk pojawiły się co prawda paski z ikonami, ale przy próbie uruchomienia dostaję informację: "ta komenda będzie obsługiwana w przyszłości".

Taki sam przypadek miałem wcześniej wersji testowej. Myślałem, że będzie lepiej w wersji komercyjnej. Proszę o poradę co źle robię?

Wersja jednostanowiskowa. ZWCAD Standard. Wersja z 05.2009.

Pozdrawiam

Link to comment
Share on other sites

Przyznam, że objawy przez Pana przedstawione, są zaskakujące. Proszę jeszcze o informację przy próbie wywołania jakich poleceń pojawia się ten komunikat.

Pisze Pan rónież, że pojawiają się ikonki - to ok, pojawienie sie ikonek znaczy, że poprawnie zostało wczytane menu, ostatnim krokiem koniecznym do działania nakładek jest wczytanie aplikacji. Należy to zrobić przy każdym uruchomieniu programu ZWCAD, a czasem przy każdym otwieranym rysunku. Wczytania nakładki można dokonać przez pierwszą ikonkę z lewej, lub poleceniem appload. Bardziej szczegółowo opisane jest to w instrukcji.

Link to comment
Share on other sites

Taki komunikat błędu występuje jeśli plik nie zostanie poprawinie wczytany. Może to być spowodowane na kilka sposobów.

Jednym z nich jest zablokowanie dostępności makr. W trakcie wczytywania aplikacji powinien się pojawić komunikat z pytaniem, czy pozwolić na pracę makr. należy wcisnąć przycisk "Enable Macros" Jak na załączonym obrazku.

Innym powodem błędnego wczytywania pliku mogą być ograniczenia systemu Windows Vista. W tym wypadku, aby program działał poprawnie, instalator musi być uruchomiony na koncie z prawami administratora. Należy też wyłączyć funkcję kontroli kona użytkownika. (Panel Sterowania -> Konta Użytkowników -> Włącz lub wyłącz funkcję kontroli konta użytkownika). Następnie polecam odinstalować nakładkę Tools i zainstalować ją ponownie.

post-127-1348487272,0973_thumb.jpg

Link to comment
Share on other sites

  • 2 weeks later...

Wracam do tematu nakładek.

W domu instalowałem na dwóch komputerach z Windows XP Home, natomiast w pracy na Windows XP Professional. Efekt jak na początku. W żadnym wypadku nie wyskakuje komunikat o zezwolenie na makra. Nie możliwe, żebym tylko ja miał takie problemy? Staram się postępować zgodnie z instrukcją. Może to wina Windowsa?, a może antywirusa (chociaż w domu mam NOD-a, a w pracy McAfee).

Może ktoś miał takie problemy? bo przyznaję, że przydałyby się te nakładki.

Pozdrawiam

Link to comment
Share on other sites

Konsultowaliśmy Pański problem z producentem ZWCADa. Problem jest taki, że nakładki nie będą działały na wersji standard. Rozwiązaniem jest zainstalowanie wersji profesional, aktywowanie jej kluczem sprzętowym wersji standard. To rozwiązanie spowoduje, że będzie się wyświetlał komunikat, o ograniczeniach wersji standard, ale pozwoli na działanie nakładek.

Link to comment
Share on other sites

  • 2 weeks later...

Witam,

Zgodnie z tym co wyczytałem w dokumentacji ZwCADa VBA nie działa w wersji Standard, w której też nie ma edytora VBA. Ja używam wersji PRO i w niej wszystko jest OK.

Chciałbym się jednak upewnić na 100% i dlatego kieruję do Państwa poniższe pytanie:

- Czy makra w Visual Basic'u działają (dają się uruchomić) w wersji ZwCAD Standard, czy tylko jest to możliwe w wersji ZwCAD Professional?

z góry dziękuję za informację

pozdrawiam

Link to comment
Share on other sites

Witam,

Wersja PRO ma pełne wsparcie VB.

W wersji Standard jest obecnie problem ze skryptami VB, co można jednak łatwo obejść. Wystarczy zainstalować wersję PRO. Jeśli ktoś ma klucz z wersji Standard, to po starcie wyświetli się komunikat o braku licencji na bryły, natomiast VB będzie działał poprawnie.

Pozdrawiam

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share