Błędy ZWCAD+ 2014 Pro


wojtur81
 Share

Recommended Posts

Witam,

 

W dniu dzisiejszym pojawił mi się taki  oto błąd. Wszystkie teksty zostały zastąpione przez prostokąty - jak w załączonym zrzucie ekranu (zw1). Kidy klikam na taki element w oknie właściwości pokazuje, że jest to tekst, natomiast w oknie zawartość widnieje właściwa treść. Restartowanie programu, audyt, purge itp nic nie dają. Nadmienię, że wczoraj instalowałem lispa do przyspieszania kopiowania tekstów dostępnego na forum. Po zainstalowaniu lispa stwierdziłem, że kopiowanie działa z lekkim opóźnienim, więc usunąłem lispa. Wtedy mniej więcej teksty zaminiły się na prostokąty.

 

Odnotowuję również problem z trimowaniem względem wybranego obiektu. Przy wybraniu kilku elementów do przycięcia (zaznaczenie prostokątne) - elementy są docinane wedle el. docinającego ale po różnych jego stronach. Jedynie przy użyciu fence jest ok.

 

Jest również problem z łapaniem punktu przecięcia elementów, którego ZW CAD nie widzi. Plik jest spłaszczony i elementy są na poziomie zero.

 

Jest jeszcze kilka innych błędów, ale to w innym terminie.

post-732-0-17920800-1393499161_thumb.jpg

Link to comment
Share on other sites

Pomogło, dziękuję.

 

W załączniku sekwencja zrzutów obrazujących problem z komendą trim. Zaznaczam, że nie zawsze tak się dzieje, ale trudno zlokalizować okoliczności w jakich się on pojawia.


Dodatkowo sugestia. W AutoCADzie komenda fillet z przytrzymanym SHIFT łączy element. ZWCAD niestety nie posiada takiej funkcjonalności. Oczywiście są problemy jeśli element "pływają" w trzecim wymiarze, tj. pomimo, że w oknie właściwości wyświetlane jest z=0, lub elevation = 0, ale przecież możnaby dodać do filetowania z SHIFT zerowanie parametru z lub elev elementów. Takie rozwiązanie bardzo ułatwiłoby rysowanie!

post-732-0-86439100-1393501580_thumb.jpg

post-732-0-83482400-1393501583_thumb.jpg

post-732-0-84289700-1393501586_thumb.jpg

Link to comment
Share on other sites

Kolejne błędy w programie:

 

1. Komenda 'change', przy parametrze 'all' wybiera wszystkie elementy, ale w oknie properties widnieje 'no selection' ->komenda change bezużyteczna

2. 'Quick select' przy wyborze wg. np koloru spoza podstawowej palety (256), wybiera wszystkie elementy w rysunku bez względu na kolor ->quick select bezużyteczny

3. Na siedmiu na siedem stanowisk odnotowujemy bardzo spadającą wydajnośc programu i poważne lagi przy edycji plików z podpiętymi xrefami. Dla porównania ACAD z identycznymi plikami radzi sobie o wiele lepiej ->na obecnym etapie rozwoju programu praca zespołowa wydaje się być mocno utrudniona...

Link to comment
Share on other sites

Kolejne błędy w programie:

 

1. Komenda 'change', przy parametrze 'all' wybiera wszystkie elementy, ale w oknie properties widnieje 'no selection' ->komenda change bezużyteczna

2. 'Quick select' przy wyborze wg. np koloru spoza podstawowej palety (256), wybiera wszystkie elementy w rysunku bez względu na kolor ->quick select bezużyteczny

 

1. Na czym polega bezużyteczność polecenia? Testowałem różne opcje z linii poleceń i wszystko było OK. Poniżej film.

2. Nie stwierdziłem nic takiego. Poniżej film.

 

change

Link to comment
Share on other sites

Hmm, nie mam QT na komputerze, ale tak, ma Pan rację co do pktu pierwszego. Komenda change nie implikuje zmiany statusu okna properties z 'no selection', również w ACAD. W tym miejscu zagalopowałem się. Co do punktu 2 to podtrzymuję to co napisałem wcześniej. Tj. po wybraniu w oknie 'properties' funkcji 'qselect' i załóżmy przyjęciu parametru wyboru wg. koloru o współrzędnych RGB wszystkie elementy zostają wybrane, bez względu na kolor. Zgłaszam uwagi bo mam nadzieję, że może ktoś już się z tym spotkał i zna rozwiązanie. 

 

KOLEJNE dwa kamyki do ogródka...

 

1. W pliku przesłanym od branż (zapisane w ACAD2012 w wersji Mechanical lub Civil, nie wiem dokładnie) nie możemy użyć komendy copy, ponieważ zwyczajnie nie działa. Wyskakuje coś w rodzaju 'copy to clipboard failed'. Ten błąd jest nam znany z ACAD i dotyczy el. proxy. Niestety taki sam problem dotyczy ZWCAD, z tym, że na forach ZWCAD nie odnalazłem póki co rozwiązania. Jest to o tyle upierdliwe, że dotyczy każdego pliku do którego podepniemy felerny plik.

 

2. Podczas wstawiania fragmentu tabelki z open office, excell (jako obiekt OLE poprzez ctrl+c, ctrl+v) następuje mająca znamiona przypadkowej zmiana kolorów zawartości niektórych okienek

Link to comment
Share on other sites

Witam

Testowałem u siebie funkcje qselect po kolorze z palety True Color i elementy zostały wybrane poprawnie.

 

post-325-0-48769400-1393921587_thumb.png post-325-0-99043000-1393921626_thumb.png

 

Proszę o przesłanie przykładowego pliku w którym problem występuje na pomoc@dobrycad.pl

 

Pozdrawiam

Link to comment
Share on other sites

HA! Słusznie, automatycznie jest ustawione na 'exclude from selection set', stąd nieporozumienie. Przyzwyczajenia z ACAD :) Problem był przeze mnie wydumany! Działa.

 

Przesyłam filmik z problematycznym trimowaniem, bo to najbardziej daje mi w kość. Mam nadzieję, że i tym razem jest to moje niedopatrzenie i jest oczywiste rozwiązanie.

Video4.avi

Link to comment
Share on other sites

  • 3 months later...

Witam!

Pracuję w pliku ze zmienionym układem współrzędnych (obrócony o 90st wzgl. WORLD). Po zamknięciu pliku i programu i ponownym uruchomieniu tego pliku otwiera mi się w globalnym układzie współrzędnych. Ponadto likwiduje mi podział ekranu na viewports.

Link to comment
Share on other sites

Witam! Mam ten sam problem. Tak samo dzieje się po przejściu z layoutu do przestrzeni modelu. Widok wraca do globalnego układu współrzędnych. Pojawił się po aktualizacji do najnowszej wersji tj. 2014-04-27(21135). Ponadto problem z błędnym docinaniem wciąż nie został rozwiązany.

Link to comment
Share on other sites

Nie tylko ten problem nie został rozwiązany.

Kopiowanie tekstów jak było uciążliwe tak jest nadal. Wydaje mi się, że to jedna z podstawowych rzeczy, która powinna mieć nadany priorytet natychmiastowej wykonalności, ale widocznie w siedzibie ZWCADA uważają, że to żaden problem. Dziwne, że Panowie z polskiego oddziału potrafili napisać szybko skrypt, który problem rozwiązywał, a ZWSOFT problem pominął przy wydaniu aktualizacji...

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share