[ZwCAD 2014] _menuload - Błąd


e_CAD
 Share

Recommended Posts

Witam,

 

Chciałbym zwrócić uwagę na błąd/nieprawidłowe działanie komendy _menuload, która w ZwCAD+ 2012 działała prawidłowo.

 

Mianowicie wywołanie:

(command "_menuload" "c:/przykladowe_menu.mnu")

 

zamiast wczytywać menu z pliku "przykladowe_menu.mnu" tak jak to dzieje się w ZwCAD+ 2012, w ZwCAD+ 2014 otwiera okno "Dostosowanie menu".

 

 

Dodam, że ręczne wczytanie tego samego pliku "przykladowe_menu.mnu" działa prawidłowo i menu się wczytuje.

 

Czy można liczyć na rozwiązanie tego problemu w wersji finalnej ZwCAD+ 2014?

 

 

pozdrawiam

Link to comment
Share on other sites

Witam Zgłoszę to ale obawiam się, że to było działanie celowe i działanie programu w tym zakresie nie zostanie zmienione. Polecenie menuload otwiera OKNO , proszące Użytkownika o wskazanie pliku i to działa poprawnie. Aby rozwiązać niedogodność proszę przez użyciem funkcji _menuload ustawić zmienną systemową filedia na 0. i przywrócić jej wartość po użyciu menuload. Czyli nie teraz a w poprzednich wersjach programu był błąd, polegający na lekceważeniu wartości zmiennej systemowej filedia. Pozdrawiam

Link to comment
Share on other sites

alternatywne podejście:

 przy danej wersji nakładki e-cad, wykonujemy export ustawień z 2012+ pro i potem import ustawień do 2014+ pro ... mi tak zadziałało

(plusem tego jest aktywacja ulubionych pasków narzędziowych i ustawień profilu w 2014+ pro,  używanych wczesniej w 2012+ pro)

Edited by Martin_S
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share