Problem z instalacją oficjalnej wersji [rozwiązany]


karuul
 Share

Recommended Posts

WItam 

mam problem z instalacja zwcad 2017 po ściągnięciu pliku uruchamiam go, wypakowuje się, opala się kreator instalacji klikam zainstaluj i nic sie nie dzieje poza tym, że przycisk zainstaluj robi się szary a przy zwcad 2017 jest zielony ptaszek.Dodam jeszcze,że mam zainstalowaną wersję rc której nie mogę odinstalować przez plik w folderze programu (w panelu sterowania niema zwcad) może to ma jakiś związek.

Przy próbie deinstalacji wyrzuca komunikat "Nie znaleziono punktu wejścia procedury RegDeleteTreeW w bibliotece ADVAPI32.dll"

vernum:2016.09.30(10203)

 

Edited by karuul
Link to comment
Share on other sites

Witam

Aby odinstalować ZWCAD 2017, proszę uruchomić pasek poleceń Windows poprzez Start->Uruchom->cmd i wkleić nast. linki:

MsiExec.exe /X{26A7C767-A001-0000-A001-F87888BABDCA}

oraz:

MsiExec.exe /X{26A7C767-A001-1045-A101-F87888BABDCA}

dla wersji ENG - drugi będzie taki:

MsiExec.exe /X{26A7C767-A001-1033-A101-F87888BABDCA}

 

Pozdrawiam

Link to comment
Share on other sites

Zarejestrowałem podobne problemy. 

Niestety nie udało mi się znaleźć wyjasnienia a rozwiażania raczej siłowe:

Symptomy u mnie : 

1. Identyczne objawy jak u Pana. Nie znalazłem eleganckiego rozwiązania, po prostu z backupa odtworzyłem cały Win7 .
   Nie pamietam dokladnie ale może zainstalowałem równolegle dwa ZWCAD'y w róznych wersjach kernela  : 

  Od strony systemu są wtedy kłopoty. Np. ZWCAD'a 2017 ( vernum 10726) i Architecture mającą w rejestrze część danych wspólnych.
   Powoduje to pomieszanie dll i i wpisów w rejestrze dot GUID obiektów OLE . 
  Instalator bezwzględnie powinien ostrzec o wykryciu równoległej innej wersji kernela ZWCAD'a  i odmówić instalacji .
  Hipoteza: Może instalacje wtedy nie są finalizowane i nastepuje crash bez ostrzeżenia użytkownika  co. np powoduje brak utworzenia exeka Uninstall ?

  Proponuje uczulic na to ZWSOFT.

2. Stwierdziłem także kilkukrotnie, przy testach róznych wersji beta długie czasy instalacji modułu Prerequisities\DotNetFX40 (widać taki katalog ktory tworzy ZWCAD podczas procesu instalacji )  .  Moduł ten zawieszał cała instalację.

   Ja poradziłem sobie niestety znowu siłowo: Kill thread instalatora w Managerze Zadań Windows  i równolegle odcięcie komputera od sieci. I dokończenie instalacji z odcięta siecią.  Technologia DotNET to strasznie zamulający element Windows o dosyć miernej reputacji.  Jako programista jak mogę to go unikam ...

Pozdrawiam,
J.

Link to comment
Share on other sites

O...

Kolega @Adam podal znacznie elegantrze rozwiązanie tuż przede mną.

Recovery calego Win7 to skuteczne do bólu rozwiązanie ale to armata na wróble...   

Mam trochę obawy czy GUID;y z lini komend konkretnych instalek nie będą inne jesli pojawią się podobne problemy w kolejnych edycjach instalatorów. 

Dziękuję jednak za to rozwiązanie. 

Pozdrawiam

J.

Edited by JasW
Link to comment
Share on other sites

  • dmatusz3 changed the title to Problem z instalacją oficjalnej wersji [rozwiązany]
  • dmatusz3 locked this topic
Guest
This topic is now closed to further replies.
 Share