Blok w wielolinii odniesienia


sanitarnik
 Share

Recommended Posts

Witam wszystkich,
To jest mój pierwszy post na forum także proszę o wyrozumiałość.
Chciałem zrobić opisy z użyciem wielolinii odniesienia i "zagnieżdżonego" w niej bloku, tzn. wykorzystania w wielolinii bloku z atrybutami zamiast zwykłego tekstu wielowierszowego, i napotkałem problem. Blok użyty w wielolinii nie trzyma wyglądu bloku źródłowego po pierwsze jeżeli chodzi o położenie tekstu jak i o parametry atrybutów. Mam tu na myśli np. niewidoczność atrybutu. Pomimo tego, że akurat w tym przypadku, parametr atrybutu "moc" jest ustawiony jako niewidoczny, to w bloku użytym w wielolinii mimo wszystko się wyświetla. Po rozbiciu wielolinii blok wyświetla się już poprawnie.
W załączeniu plik obrazujący problem.

ZWCAD+ 2014 vernum = "2014.06.25(24082)" oraz ZWCAD+ 2015 beta.

Blok w wielolinii odniesienia.dwg

Link to comment
Share on other sites

  • 7 months later...

Hmm ja pokombinowałbym tymczasowo z poleceniem Group Ungroup. Grupa zachowuje sie tak jak 1 element, i jest możliwość zmieniania zasięgu strzałki, w przypadku zmiany zmiennych atrybutowych rozgrupowujemy na chwile , zmieniamy dane i ponownie grupujemy. Obiekty zgrupowane poddają sie  lispom robiacych zestawienia.

 

 

 

1. post-140-0-65944500-1431376081_thumb.jpg

2. post-140-0-93944100-1431376081_thumb.jpg

3. post-140-0-16795400-1431376082_thumb.jpg

4. post-140-0-42761000-1431376082_thumb.jpg

5. post-140-0-70788900-1431376082_thumb.jpg

 

5. ---> 1. itd. kopiowanie i procedura j.w.


Wariant 2 ..korekta bloku, ale nie wiem jak moc zdeaktywować w multiliniiodniesienia, bo deaktywacja zmiennej atrybutowej to łatwo zrobić jako niewidzialną w samym bloku.

 

post-140-0-69342700-1431377488_thumb.jpg

 

Blok w wielolinii odniesienia-1.dwg

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share