Testujemy nową Betę


Recommended Posts

W dniu 12.02.2021 o 15:52, dmatusz3 napisał:

To w obrębie wersji ZWCAD 2021 VERNUM= 2021.02.09(62580).

Niedawno otrzymaliśmy do sprawdzenia. Gdyby ktoś miał ochotę spojrzeć, to proszę o informacje, prześlę linki.

 

Chętnie przetestuje tą wersję programu.
Proszę tylko o odpowiedź :
- Czy klucz sieciowy do wersji pełnej będzie działał na tej wersji programu ?
- Czy import ustawień z wersji SP1 do tej wersji przebiega "łagodnie i bezproblemowe" ?

Link to comment
Share on other sites

vernum = "2021.02.09(62580)_x64"

Będę w tym poście wpisywał swoje spostrzeżenia dotyczące tej wersji programu

1. WŁĄCZONE OSNAPY PODCZAS ZOOMOWANIA - od kilku wersji zwcad (15+ tego nie miał) przy użyciu komendy "_zoom" "_w" (zoom window) program chce łapać pkt charakterystyczne. Dla mnie jest to błąd, który powoduje bardzo często "randomowe" powiększenie okna.
2. KOPIOWANIE PRZEZ SCHOWEK - zauważyłem, że w szczególności wersja 2021 ZWCADa bardzo dziwnie się zachowuje podczas kopiowania elementów do schowka (ctrl+c). Program "zawiesza się" na 3, 4 sekundy. Myślałem, że jest to tylko i wyłącznie problem występujący na moim komputerze, ale okazuje się, że na innych komputerach w biurze występuje takie zachowanie się programu.

Link to comment
Share on other sites

18 minut temu, BKW napisał:

1. WŁĄCZONE OSNAPY PODCZAS ZOOMOWANIA - od kilku wersji zwcad (15+ tego nie miał) przy użyciu komendy "_zoom" "_w" (zoom window) program chce łapać pkt charakterystyczne. Dla mnie jest to błąd, który powoduje bardzo często "randomowe" powiększenie okna.

Myślę, że lepszym rozwiązaniem byłoby wprowadzenie zmiennej, która daje możliwość włączania i wyłączania łapania punktów charakterystycznych (OSNAP) w trakcie wykonywania komendy _zoom.

 

21 minut temu, BKW napisał:

2. KOPIOWANIE PRZEZ SCHOWEK - zauważyłem, że w szczególności wersja 2021 ZWCADa bardzo dziwnie się zachowuje podczas kopiowania elementów do schowka (ctrl+c). Program "zawiesza się" na 3, 4 sekundy. Myślałem, że jest to tylko i wyłącznie problem występujący na moim komputerze, ale okazuje się, że na innych komputerach w biurze występuje takie zachowanie się programu.

U mnie też widoczna jest krótka zawieszka przy kopiowaniu przez schowek. Czas zależny jest od ilości kopiowanego materiału :)).
Przy kopiowaniu większej ilości danych dobrze widać po pasku 'ładowania' na dole, że program w tle wykonuje 'operacje'...

Link to comment
Share on other sites

Na plus dla tej wersji poprawienie działania PPM.
Udało się przywrócić prawidłowe funkcjonowanie PPM zwłaszcza dla powtarzania komendy KOPIUJ (COPY).

Betę testuję od kilku dni, ale odnoszę wrażenie jakby program działał płynniej i stabilniej niż SP1.
Nie wiem tylko czy to moje subiektywne odczucia, czy program rzeczywiście został usprawniony... czas pokaże...

 

Edited by Chris
Link to comment
Share on other sites

40 minut temu, BKW napisał:

vernum = "2021.02.09(62580)_x64"

Będę w tym poście wpisywał swoje spostrzeżenia dotyczące tej wersji programu

1. WŁĄCZONE OSNAPY PODCZAS ZOOMOWANIA - od kilku wersji zwcad (15+ tego nie miał) przy użyciu komendy "_zoom" "_w" (zoom window) program chce łapać pkt charakterystyczne. Dla mnie jest to błąd, który powoduje bardzo często "randomowe" powiększenie okna.
2. KOPIOWANIE PRZEZ SCHOWEK - zauważyłem, że w szczególności wersja 2021 ZWCADa bardzo dziwnie się zachowuje podczas kopiowania elementów do schowka (ctrl+c). Program "zawiesza się" na 3, 4 sekundy. Myślałem, że jest to tylko i wyłącznie problem występujący na moim komputerze, ale okazuje się, że na innych komputerach w biurze występuje takie zachowanie się programu.

3. BRAK ZAWIJANIA WSZYSTKICH "PODOPCJI" DLA KOMENDY - na zrzucie poniżej widać, że wywołanie np. "-layer" powoduje brak pokazania wszystkich dostępnych opcji "podkomend". W zw 15+ realizowane to było tak, że opcje które się nie zmieściły w zakresie paska komend były wyświetlane poniżej (znane z wielu programów "zawijanie wierszy")

obraz.png.39f619276695c55cae1b60c19571a040.png

Link to comment
Share on other sites

3 minuty temu, Chris napisał:

Na plus dla tej wersji poprawienie działania PPM.
Udało się przywrócić prawidłowe funkcjonowanie PPM zwłaszcza dla powtarzania komendy KOPIUJ (COPY).

Betę testuję od kilku dni, ale odnoszę wrażenie jakby program działał płynniej i stabilniej niż SP1.
Nie wiem tylko czy to moje subiektywne odczucia, czy program rzeczywiście został usprawniony... czas pokaże...

 

Też odnoszę wrażenie (a testuję dopiero 2 godziny), że program działa szybciej.
Natomiast mam wrażenie (oczywiście z założeniem krótkiego czasu testowania), że program jakoś tak dziwnie (inaczej) wymusza działanie OSNAPÓW przy dużej możliwości ich wyboru.

Link to comment
Share on other sites

Niestety ciągle mogę złapać metkę TOOLTIPS, przez co program jakby na moment stawał się nieaktywny (w trakcie kiedy złapię metkę program nie wykonuje komendy - pokazuje się kursor taki, jak poza obszarem roboczym - poza modelem).
Próbowałem powtórzyć to w konkurencyjnych CADach, niestety tylko ZWCAD 'daje taką możliwość'...
Szczegółowy opis pod linkiem:

 

Edited by Chris
Link to comment
Share on other sites

7 minut temu, BKW napisał:

Też odnoszę wrażenie (a testuję dopiero 2 godziny), że program działa szybciej.
Natomiast mam wrażenie (oczywiście z założeniem krótkiego czasu testowania), że program jakoś tak dziwnie (inaczej) wymusza działanie OSNAPÓW przy dużej możliwości ich wyboru.

Ja od zawsze działam na wszystkich włączonych SNAPACH i w tej wersji wg mnie działają lepiej...
Co prawda nie miałem jeszcze okazji testować tej wersji na plikach, gdzie mam dużą ilość bloków i podkładów, ale wkrótce będę miał porównanie...
U mnie zawsze problem z OSNAPAMI pojawiał się z blokami wstawionymi z ArchiCada...

Link to comment
Share on other sites

3 minuty temu, Chris napisał:

Niestety ciągle mogę złapać metkę TOOLTIPS, przez co program jakby na moment stawał się nieaktywny (w trakcie kiedy złapię metkę program nie wykonuje komendy - pokazuje się kursor taki, jak poza obszarem roboczym - poza modelem).
Próbowałem powtórzyć to w konkurencyjnych CADach, niestety tylko ZWCAD 'daje taką możliwość'...
Szczegółowy opis pod linkiem:

 

Udało mi się to zachowanie powtórzyć. Musiałem się "natrudzić", ale udało się.

zw2021sp2_smarttrack.gif.126f5b35dd2c256695009753715e9a6f.gif

Link to comment
Share on other sites

18 minut temu, BKW napisał:

Udało mi się to zachowanie powtórzyć. Musiałem się "natrudzić", ale udało się.

U mnie problem polega na tym, że ja w ogóle nie muszę trudzić się, żeby złapać metkę.
Praktycznie za każdym razem kiedy pojawia się metka mogę ją bez problemu złapać.
Gdybym łapał ją sporadycznie to nie byłoby problemu, niestety dzieje się to dość często...

Mój trop dotyczy myszki i jej rozdzielczości, ale nie wiem czy to dobry kierunek...
Wcześniej używałem myszki Logitech G602 i działałem na DPI 1600. Problem z łapaniem metki występował sporadycznie...
Jakiś czas temu przesiadłem się na mysz Logitech G604 i działam na DPI 3600.
Wydaje mi się, że właśnie po zmianie myszki i DPI problemy z łapaniem metki TOOLTIPS nasiliły się.

Link to comment
Share on other sites

13 minut temu, Chris napisał:

U mnie problem polega na tym, że ja w ogóle nie muszę trudzić się, żeby złapać metkę.
Praktycznie za każdym razem kiedy pojawia się metka mogę ją bez problemu złapać.
Gdybym łapał ją sporadycznie to nie byłoby problemu, niestety dzieje się to dość często...

Mój trop dotyczy myszki i jej rozdzielczości, ale nie wiem czy to dobry kierunek...
Wcześniej używałem myszki Logitech G602 i działałem na DPI 1600. Problem z łapaniem metki występował sporadycznie...
Jakiś czas temu przesiadłem się na mysz Logitech G604 i działam na DPI 3600.
Wydaje mi się, że właśnie po zmianie myszki i DPI problemy z łapaniem metki TOOLTIPS nasiliły się.

Może tak być, że DPI ma znaczenie. Właśnie zmieniłem u siebie w myszce na najwyższą (3200) i o wiele łatwiej mi złapać metkę. (mysz A4Tech Bloody V3)

Link to comment
Share on other sites

Zrobiłem dzisiaj kilka testów na plikach, z którymi miałem dość spore problemy jeśli chodzi o działanie OSNAP.
W trakcie wykonywania kilku komend (np. STRETCH) program potrzebował 2-3 sekund żeby wyświetlił się znacznik punktu charakterystycznego (SNAP MARKER)
W testowanej wersji BETA widać znaczącą poprawę działania funkcji OSNAP, chociaż jest jeszcze wiele do zrobienia. 
Mam nadzieję, że do wydania SP2 a następnie wersji 2022 uda się jeszcze podkręcić działanie OSNAP.

Link to comment
Share on other sites

W dniu 25.02.2021 o 14:04, BKW napisał:

3. BRAK ZAWIJANIA WSZYSTKICH "PODOPCJI" DLA KOMENDY - na zrzucie poniżej widać, że wywołanie np. "-layer" powoduje brak pokazania wszystkich dostępnych opcji "podkomend". W zw 15+ realizowane to było tak, że opcje które się nie zmieściły w zakresie paska komend były wyświetlane poniżej (znane z wielu programów "zawijanie wierszy")

obraz.png.39f619276695c55cae1b60c19571a040.png

4. BRAK SORTOWANIA (lista rozwijana warstw, bloków) - na zrzucie pokazuje listę rozwijaną wyboru strzałki w stylu wymiarowym. Lista nie jest posortowana alfabetycznie, ale (mam wrażenie), że bloki układają się wg "daty" dodania do zbioru rysunku. Zauważyłem to, gdy skopiowany przed chwilą blok, który powinien znaleźć się na tej liście mniej więcej w środku, wylądował na samym końcu.
W poprzedniej wersji programu podobne zjawisko zauważyłem przy liście rozwijanej warstw.

obraz.png.dbf14fbbe9ff4e25020a4a407b31ce16.png

Link to comment
Share on other sites

16 godzin temu, BKW napisał:

4. BRAK SORTOWANIA (lista rozwijana warstw, bloków) - na zrzucie pokazuje listę rozwijaną wyboru strzałki w stylu wymiarowym. Lista nie jest posortowana alfabetycznie, ale (mam wrażenie), że bloki układają się wg "daty" dodania do zbioru rysunku. Zauważyłem to, gdy skopiowany przed chwilą blok, który powinien znaleźć się na tej liście mniej więcej w środku, wylądował na samym końcu.
W poprzedniej wersji programu podobne zjawisko zauważyłem przy liście rozwijanej warstw.

Nie wiem jak to jest z listą bloków ale jeśli chodzi o warstwy, to brak sortowania się pojawia, gdy ilość warstw przekroczy wartość zmiennej MAXSORT (domyślnie jest ustawiona chyba na 2000).  Może to też wpływa na sortowanie listy bloków?

Link to comment
Share on other sites

To chyba ten temat sortowania powinien być wyczerpany. Swoją drogą, ciekaw jestem dlaczego domyślny pułap sortowania warstw/bloków jest ustawiony tak nisko? Osiągnięcie liczby 1000 warstw przy pracy z XREF to nic trudnego. Czy liczba sortowanych elementów może mocno wpływać na wydajność programów CAD?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share