Problem z zamykaniem/cofaniem polilinii


Recommended Posts

Witam

Często łapie ZWCAD (vernum = "2020.11.11(60805)_x64") na tym, że w trakcie rysowanie polilinii gubi literowe opcje. Widać to doskonale na załączonym gifie - gdy jestem w pobliżu linii, którą rysuję to komenda pamięta, że wpisałem Z by zamknąć (podobnie jest z C by cofnąć). Jednak wystarczy, że kurs trochę odjedzie od linii i nagle wpisane Z znika. Naciśnięcie enter w tej sytuacji kończy rysowanie polilinii na ostatnim punkcie zamiast zamknąć całość. Co gorsze nie ma reguły z tym - zdarza się to całkowicie losowo i nie zauważyłem, by było uzależnione od czegoś (pracuję zarówno na rysunkach stworzonych od podstaw przeze mnie, jak i na rysunkach przesłanych do mnie i na rysunkach z XREF-ami - w każdym "typie" rysunku zdarza się to samo).

pozdrawiam
Mateusz

polinia2.gif

Link to post
Share on other sites
  • 3 months later...

Witam ponownie

Uaktualniam ten wątek o kolejne zachowanie. Tym razem wyłapałem to przy rozciąganiu elementów. Wpisywana wartość znika w trakcie wpisywania i po zatwierdzeniu enterem:

- albo rozciągany element ucieka
- albo poprawnie się rozciąga

Proszę zwrócić uwagę na moment wpisywania cyfry "30" - za pierwszym razem pasek dynamiczny widoczny jest przy "3" i znika przy wpisaniu "0" (w zasadzie ukrywa cyfrę i wyświetla "środek"), a obiekt źle się rozciąga. Za drugim jest dokładnie odwrotnie i jest w porządku. Coś chyba z paskiem dynamicznym nie działa tak jak powinno, bo przy wyłączeniu go działa to poprawnie (identycznie jest przy polilinii - po wyłączeniu paska dynamicznego działa wszystko poprawnie).

pozdrawiam
Mateusz

rozciaganie.thumb.gif.f195047b0e69d123c8b516372c5790d4.gif

Link to post
Share on other sites

Czy mógłby Pan podesłać ten fragment rysunku do nas?

Rozumiem, że to jest ta sama Polilinia w obu przypadkach.

Te liczby na liniach są zrobione za pomocą wymiarów w odpowiednim stylu?

Czy po wykonaniu pierwszego rozciągania cofnął Pan operacje (undo) i wtedy się obiekt źle rozciągnął?

Link to post
Share on other sites
W dniu 2.06.2021 o 14:54, dmatusz3 napisał:

Czy mógłby Pan podesłać ten fragment rysunku do nas?

Rozumiem, że to jest ta sama Polilinia w obu przypadkach.

Te liczby na liniach są zrobione za pomocą wymiarów w odpowiednim stylu?

Czy po wykonaniu pierwszego rozciągania cofnął Pan operacje (undo) i wtedy się obiekt źle rozciągnął?

1) Rysunek już macie, bo to jest wciąż ten sam, na którym miałem problemy z szykami dynamicznymi.

2) Dokładnie tak - to jest to samo miejsce, to samo strzemię.

3) Nie rozumiem o jaki odpowiedni styl może Pan pytać. Jest to styl zrobiony w ZWCadzie, zrobiony przeze mnie. Nie ma opisu skalowanego (tj. przygotowany jest pod skalę 1:1 - nie zmieniam skali tym przełącznikiem w dolnym prawym rogu ekranu). W przesłanym rysunku jest to styl wymiarowania "R-B25_prety_pod"

4) Odwrotnie. Najpierw obiekt źle się rozciągnął, następnie cofnąłem (undo) i wtedy obiekt dobrze się rozciągnął.

Co do pierwszego wątku w tym temacie, czyli przy przesunięciu kursora znika literka "z" (zamknięcie), gif pokazuje moment, gdy robiłem obrys na przesłanym do mnie podkładzie. Ale problem ten pojawia się także przy rysowaniu. Nie jest to proste do odtworzenia, bo nie zawsze tak się dzieje.

Rozciąganie sprawdziłem na innym pliku i jak widać poniżej problem i tu się pojawia. Za pierwszym razem poprawnie, po cofnięciu i ponowieniu rozciągnęło gdzieś w bliżej nie określone miejsce.

rozciaganie2.thumb.gif.fed6de4eadab6614ee22e39b54a755d3.gif

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...